import re
regex = re.compile(r"\A[a-zA-Z0-9\s\p{Han}]+\z")
test_str = "总理话音一落 部门即抓落实 End"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")