$re = '/\A[a-zA-Z0-9\s\p{Han}]+\z/';
$str = '总理话音一落 部门即抓落实 End';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);