package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`'[^']*?'(*SKIP)(*F)|AND`)
var str = `parameter_1 >= '23' AND parameter_2 like 'cucurigu AND \picaso' AND parameter_3 IS NULL`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}