// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"'[^']*?'(*SKIP)(*F)|AND").unwrap();
let string = "parameter_1 >= '23' AND parameter_2 like 'cucurigu AND \\picaso' AND parameter_3 IS NULL";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}