re = /'[^']*?'(*SKIP)(*F)|AND/
str = 'parameter_1 >= \'23\' AND parameter_2 like \'cucurigu AND \\picaso\' AND parameter_3 IS NULL'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end