#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!\ball\b).*$"
Local $sString = "all" & @CRLF & _
"" & @CRLF & _
"all-test" & @CRLF & _
"" & @CRLF & _
"test-all" & @CRLF & _
"" & @CRLF & _
"1all" & @CRLF & _
"" & @CRLF & _
"all2" & @CRLF & _
"" & @CRLF & _
"all1-test" & @CRLF & _
"" & @CRLF & _
"test-all1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")