$re = '/^(?!\ball\b).*$/m';
$str = 'all
all-test
test-all
1all
all2
all1-test
test-all1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);