re = /^(?!\ball\b).*$/m
str = 'all
all-test
test-all
1all
all2
all1-test
test-all1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end