const regex = /^(?!\ball\b).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!\\ball\\b).*$', 'gm')
const str = `all
all-test
test-all
1all
all2
all1-test
test-all1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}