#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!gmail)(.*mail.*?)\s+(.*)\s+A\s+(.*)$"
Local $sString = "xxx-yy.biz. 39405 A 156.154.66.33" & @CRLF & _
"mail.global.com. 3464 A 115.113.9.64" & @CRLF & _
"xyx xyx xyx" & @CRLF & _
"webmail.xyz.com. 1463 A 115.113.9.64" & @CRLF & _
"gmail.com. 3464 A 115.113.9.22"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")