re = /^(?!gmail)(.*mail.*?)\s+(.*)\s+A\s+(.*)$/m
str = 'xxx-yy.biz. 39405 A 156.154.66.33
mail.global.com. 3464 A 115.113.9.64
xyx xyx xyx
webmail.xyz.com. 1463 A 115.113.9.64
gmail.com. 3464 A 115.113.9.22'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end