# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!gmail)(.*mail.*?)\s+(.*)\s+A\s+(.*)$"
test_str = ("xxx-yy.biz. 39405 A 156.154.66.33\n"
"mail.global.com. 3464 A 115.113.9.64\n"
"xyx xyx xyx\n"
"webmail.xyz.com. 1463 A 115.113.9.64\n"
"gmail.com. 3464 A 115.113.9.22")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.