import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!gmail)(.*mail.*?)\\s+(.*)\\s+A\\s+(.*)$";
final String string = "xxx-yy.biz. 39405 A 156.154.66.33\n"
+ "mail.global.com. 3464 A 115.113.9.64\n"
+ "xyx xyx xyx\n"
+ "webmail.xyz.com. 1463 A 115.113.9.64\n"
+ "gmail.com. 3464 A 115.113.9.22";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}