package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[A-Z0-9]+(?:-[A-Z0-9]+)+`)
var str = `I only want the Uppercase Letters and Numbers with dashes, so it does get GC-113, AO-1-GC-113, AO-2-GC-113, which is great!
"I don't want this ------, but this is good GC-113, AO-1-GC-113, AO-2-GC-113"
BUT if I come across one where there is no space between the number, but just another character like a comma or a period then it returns a match on the entire section "GC-113,AO-1-GC-113,AO-2-GC-113"
"I don't want this ------, but this is good GC-113,AO-1-GC-113,AO-2-GC-113"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}