const regex = /\b[A-Z0-9]+(?:-[A-Z0-9]+)+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[A-Z0-9]+(?:-[A-Z0-9]+)+', 'g')
const str = `I only want the Uppercase Letters and Numbers with dashes, so it does get GC-113, AO-1-GC-113, AO-2-GC-113, which is great!
"I don't want this ------, but this is good GC-113, AO-1-GC-113, AO-2-GC-113"
BUT if I come across one where there is no space between the number, but just another character like a comma or a period then it returns a match on the entire section "GC-113,AO-1-GC-113,AO-2-GC-113"
"I don't want this ------, but this is good GC-113,AO-1-GC-113,AO-2-GC-113"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}