# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b[A-Z0-9]+(?:-[A-Z0-9]+)+"
test_str = ("I only want the Uppercase Letters and Numbers with dashes, so it does get GC-113, AO-1-GC-113, AO-2-GC-113, which is great!\n\n"
"\"I don't want this ------, but this is good GC-113, AO-1-GC-113, AO-2-GC-113\"\n\n"
"BUT if I come across one where there is no space between the number, but just another character like a comma or a period then it returns a match on the entire section \"GC-113,AO-1-GC-113,AO-2-GC-113\"\n\n"
"\"I don't want this ------, but this is good GC-113,AO-1-GC-113,AO-2-GC-113\"")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.