// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b[A-Z0-9]+(?:-[A-Z0-9]+)+").unwrap();
let string = "I only want the Uppercase Letters and Numbers with dashes, so it does get GC-113, AO-1-GC-113, AO-2-GC-113, which is great!
\"I don't want this ------, but this is good GC-113, AO-1-GC-113, AO-2-GC-113\"
BUT if I come across one where there is no space between the number, but just another character like a comma or a period then it returns a match on the entire section \"GC-113,AO-1-GC-113,AO-2-GC-113\"
\"I don't want this ------, but this is good GC-113,AO-1-GC-113,AO-2-GC-113\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}