const regex = new RegExp('^(?P<prod>\\w+)-(?P<maj>\\d).(?P<min>\\d).(?P<bug>\\d)(?:-(?P<pre>alpha|beta|rc)(?:\\.(?P<pre_n>\\d))?(?:\\.(?P<pre_x>\\w+))?(?<!centos|redhat))?(?:\\.(?P<os>centos|redhat))?(?:\\.(?P<plat>snb|ivb))?$', 'gm')
const str = `foo-1.2.3
foo-2.3.4-alpha
foo-3.4.5-rc.2
foo-4.5.6-rc.2.extra
withos-5.6.7.centos
osandextra-7.8.9-rc.foo.redhat
os_and_plat-4.4.4-rc.1.foo.centos.ivb
issue-0.1.0-beta.redhat.snb
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}