use strict;
my $str = 'foo-1.2.3
foo-2.3.4-alpha
foo-3.4.5-rc.2
foo-4.5.6-rc.2.extra
withos-5.6.7.centos
osandextra-7.8.9-rc.foo.redhat
os_and_plat-4.4.4-rc.1.foo.centos.ivb
issue-0.1.0-beta.redhat.snb
';
my $regex = qr/^(?P<prod>\w+)-(?P<maj>\d).(?P<min>\d).(?P<bug>\d)(?:-(?P<pre>alpha|beta|rc)(?:\.(?P<pre_n>\d))?(?:\.(?P<pre_x>\w+))?(?<!centos|redhat))?(?:\.(?P<os>centos|redhat))?(?:\.(?P<plat>snb|ivb))?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}