import Foundation
let pattern = #"^(?P<prod>\w+)-(?P<maj>\d).(?P<min>\d).(?P<bug>\d)(?:-(?P<pre>alpha|beta|rc)(?:\.(?P<pre_n>\d))?(?:\.(?P<pre_x>\w+))?(?<!centos|redhat))?(?:\.(?P<os>centos|redhat))?(?:\.(?P<plat>snb|ivb))?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
foo-1.2.3
foo-2.3.4-alpha
foo-3.4.5-rc.2
foo-4.5.6-rc.2.extra
withos-5.6.7.centos
osandextra-7.8.9-rc.foo.redhat
os_and_plat-4.4.4-rc.1.foo.centos.ivb
issue-0.1.0-beta.redhat.snb
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)