using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.(fa-(?:\w+(?:-)?)+):before\s+{\s*content:\s*""(.+)"";\s+}";
string input = @".fa-glass:before {
content: ""\f000"";
}
.fa-music:before {
content: ""\f001"";
}
.fa-search:before {
content: ""\f002"";
}
.fa-envelope-o:before {
content: ""\f003"";
}
.fa-heart:before {
content: ""\f004"";
}
.fa-star:before {
content: ""\f005"";
}
.fa-star-o:before {
content: ""\f006"";
}
.fa-user:before {
content: ""\f007"";
}";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}