import re
regex = re.compile(r"\.(fa-(?:\w+(?:-)?)+):before\s+{\s*content:\s*\"(.+)\";\s+}")
test_str = (".fa-glass:before {\n"
" content: \"\\f000\";\n"
"}\n"
".fa-music:before {\n"
" content: \"\\f001\";\n"
"}\n"
".fa-search:before {\n"
" content: \"\\f002\";\n"
"}\n"
".fa-envelope-o:before {\n"
" content: \"\\f003\";\n"
"}\n"
".fa-heart:before {\n"
" content: \"\\f004\";\n"
"}\n"
".fa-star:before {\n"
" content: \"\\f005\";\n"
"}\n"
".fa-star-o:before {\n"
" content: \"\\f006\";\n"
"}\n"
".fa-user:before {\n"
" content: \"\\f007\";\n"
"}")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")