$re = '/\.(fa-(?:\w+(?:-)?)+):before\s+{\s*content:\s*"(.+)";\s+}/';
$str = '.fa-glass:before {
content: "\\f000";
}
.fa-music:before {
content: "\\f001";
}
.fa-search:before {
content: "\\f002";
}
.fa-envelope-o:before {
content: "\\f003";
}
.fa-heart:before {
content: "\\f004";
}
.fa-star:before {
content: "\\f005";
}
.fa-star-o:before {
content: "\\f006";
}
.fa-user:before {
content: "\\f007";
}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);