// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\.(fa-(?:\w+(?:-)?)+):before\s+{\s*content:\s*"(.+)";\s+}"#).unwrap();
let string = ".fa-glass:before {
content: \"\\f000\";
}
.fa-music:before {
content: \"\\f001\";
}
.fa-search:before {
content: \"\\f002\";
}
.fa-envelope-o:before {
content: \"\\f003\";
}
.fa-heart:before {
content: \"\\f004\";
}
.fa-star:before {
content: \"\\f005\";
}
.fa-star-o:before {
content: \"\\f006\";
}
.fa-user:before {
content: \"\\f007\";
}";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}