import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(js\\/(?:blog|calculators)\\/.+)((?:\\.min)?\\.js)$";
final String string = "js/main_dev.js\n"
+ "js/blog/foo.js\n"
+ "js/blog/foo.min.js";
final String subst = "$1_dev$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}