const regex = /(js\/(?:blog|calculators)\/.+)((?:\.min)?\.js)$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(js\\\/(?:blog|calculators)\\\/.+)((?:\\.min)?\\.js)$', 'mg')
const str = `js/main_dev.js
js/blog/foo.js
js/blog/foo.min.js`;
const subst = `$1_dev$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);