$re = '/(js\/(?:blog|calculators)\/.+)((?:\.min)?\.js)$/m';
$str = 'js/main_dev.js
js/blog/foo.js
js/blog/foo.min.js';
$subst = "$1_dev$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;