re = /(js\/(?:blog|calculators)\/.+)((?:\.min)?\.js)$/m
str = 'js/main_dev.js
js/blog/foo.js
js/blog/foo.min.js'
subst = '$1_dev$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result