// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
  let regex = Regex::new(r"((\[\d+:\d+:\d+ \w+\][\w ]+:)|(\[\d+:\d+:\d+ \w+ \| \w+ \d+:\d+:\d+ \w+\][\w ]+:))([ \w'.,]+)").unwrap();
  let string = "[9:14:51 AM] Jeff: If you could just do me a favoure and list all these concerns and in a mail and if you have any ideas that you might want to implement so that I can get everybodys notes.
[9:14:56 AM] Timmy: in terms of websites or domains or DNSs I have no clue about setup
[9:15:19 AM | Edited 9:15:25 AM] Jeff: That, I will get Sam and Frodo involved in
[9:16:01 AM] Jeff: I am stepping out quickly";
  let substitution = "";
  
  // result will be a String with the substituted value
  let result = regex.replace_all(string, substitution);
  
  println!("{}", result);
}