import Foundation
let pattern = #"((\[\d+:\d+:\d+ \w+\][\w ]+:)|(\[\d+:\d+:\d+ \w+ \| \w+ \d+:\d+:\d+ \w+\][\w ]+:))([ \w'.,]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
[9:14:51 AM] Jeff: If you could just do me a favoure and list all these concerns and in a mail and if you have any ideas that you might want to implement so that I can get everybodys notes.
[9:14:56 AM] Timmy: in terms of websites or domains or DNSs I have no clue about setup
[9:15:19 AM | Edited 9:15:25 AM] Jeff: That, I will get Sam and Frodo involved in
[9:16:01 AM] Jeff: I am stepping out quickly
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)