# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<img.*?\K( style="[^"]+")(?=[^>]*>)/++/mg;t' <<< "<div class=\"avatar avatar-32 clear-both\" style=\"display: none;\"><img width=\"32\" height=\"32\" src=\"http://i.stack.imgur.com/xBOdsdp.jpg?s=128&g=5&g&s=3\" alt=\"Johny\" title=\"Johny\" style=\"border: 0;\"><div></div></div>
<div class=\"avatar avatar-32 clear-both\" style=\"display: none;\"><img width=\"32\" height=\"32\" src=\"http://i.stack.imgur.com/xBOdsdp.jpg?s=128&g=5&g&s=3\" style=\"border: 0;\" alt=\"Johny\" title=\"Johny\"><div></div></div>
<div class=\"avatar avatar-32 clear-both\" style=\"display: none;\"><img width=\"32\" height=\"32\" src=\"http://i.stack.imgur.com/xBOdsdp.jpg?s=128&g=5&g&s=3\" alt=\"Johny\" title=\"Johny\"><div></div></div>"