re = /<img.*?\K( style="[^"]+")(?=[^>]*>)/m
str = '<div class="avatar avatar-32 clear-both" style="display: none;"><img width="32" height="32" src="http://i.stack.imgur.com/xBOdsdp.jpg?s=128&g=5&g&s=3" alt="Johny" title="Johny" style="border: 0;"><div></div></div>
<div class="avatar avatar-32 clear-both" style="display: none;"><img width="32" height="32" src="http://i.stack.imgur.com/xBOdsdp.jpg?s=128&g=5&g&s=3" style="border: 0;" alt="Johny" title="Johny"><div></div></div>
<div class="avatar avatar-32 clear-both" style="display: none;"><img width="32" height="32" src="http://i.stack.imgur.com/xBOdsdp.jpg?s=128&g=5&g&s=3" alt="Johny" title="Johny"><div></div></div>'
subst = '++'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result