import Foundation
let pattern = #"<img.*?\K( style="[^"]+")(?=[^>]*>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<div class="avatar avatar-32 clear-both" style="display: none;"><img width="32" height="32" src="http://i.stack.imgur.com/xBOdsdp.jpg?s=128&g=5&g&s=3" alt="Johny" title="Johny" style="border: 0;"><div></div></div>
<div class="avatar avatar-32 clear-both" style="display: none;"><img width="32" height="32" src="http://i.stack.imgur.com/xBOdsdp.jpg?s=128&g=5&g&s=3" style="border: 0;" alt="Johny" title="Johny"><div></div></div>
<div class="avatar avatar-32 clear-both" style="display: none;"><img width="32" height="32" src="http://i.stack.imgur.com/xBOdsdp.jpg?s=128&g=5&g&s=3" alt="Johny" title="Johny"><div></div></div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"++"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)