using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img.*?\K( style=""[^""]+"")(?=[^>]*>)";
string substitution = @"++";
string input = @"<div class=""avatar avatar-32 clear-both"" style=""display: none;""><img width=""32"" height=""32"" src=""http://i.stack.imgur.com/xBOdsdp.jpg?s=128&g=5&g&s=3"" alt=""Johny"" title=""Johny"" style=""border: 0;""><div></div></div>
<div class=""avatar avatar-32 clear-both"" style=""display: none;""><img width=""32"" height=""32"" src=""http://i.stack.imgur.com/xBOdsdp.jpg?s=128&g=5&g&s=3"" style=""border: 0;"" alt=""Johny"" title=""Johny""><div></div></div>
<div class=""avatar avatar-32 clear-both"" style=""display: none;""><img width=""32"" height=""32"" src=""http://i.stack.imgur.com/xBOdsdp.jpg?s=128&g=5&g&s=3"" alt=""Johny"" title=""Johny""><div></div></div>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}