#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)^([a-z]+|\d+)-([a-z]+|\d+)$"
Local $sString = "1" & @CRLF & _
"3" & @CRLF & _
"10-15" & @CRLF & _
"17" & @CRLF & _
"A" & @CRLF & _
"b" & @CRLF & _
"XX-YY" & @CRLF & _
"z" & @CRLF & _
"5-A"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")