package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)^([a-z]+|\d+)-([a-z]+|\d+)$`)
var str = `1
3
10-15
17
A
b
XX-YY
z
5-A`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}