import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)^([a-z]+|\\d+)-([a-z]+|\\d+)$";
final String string = "1\n"
+ "3\n"
+ "10-15\n"
+ "17\n"
+ "A\n"
+ "b\n"
+ "XX-YY\n"
+ "z\n"
+ "5-A";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}