// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)^([a-z]+|\d+)-([a-z]+|\d+)$").unwrap();
let string = "1
3
10-15
17
A
b
XX-YY
z
5-A";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}