package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:([a-z]+-[a-z]+)|(\d+-\d+))$`)
var str = `1
3
10-15
17
A
b
XX-YY
z
5-A`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}