$re = '/^(?:([a-z]+-[a-z]+)|(\d+-\d+))$/mi';
$str = '1
3
10-15
17
A
b
XX-YY
z
5-A';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);