import re
regex = re.compile(r"^(?:([a-z]+-[a-z]+)|(\d+-\d+))$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("1\n"
"3\n"
"10-15\n"
"17\n"
"A\n"
"b\n"
"XX-YY\n"
"z\n"
"5-A")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")