using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*(?<!search.php)\?[ft]=\d+$|^[^?]*(?<!search.php)$";
string input = @"http://www.example.com/discuss/viewtopic.php?t=19
http://www.example.com/discuss/viewforum.php?f=8
http://www.example.com/discuss/search.php?f=8
http://www.example.com/discuss/viewforum.php
http://www.example.com/discuss/search.php";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}