const regex = /.*(?<!search.php)\?[ft]=\d+$|^[^?]*(?<!search.php)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*(?<!search.php)\\?[ft]=\\d+$|^[^?]*(?<!search.php)$', 'gm')
const str = `http://www.example.com/discuss/viewtopic.php?t=19
http://www.example.com/discuss/viewforum.php?f=8
http://www.example.com/discuss/search.php?f=8
http://www.example.com/discuss/viewforum.php
http://www.example.com/discuss/search.php`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}