$re = '/.*(?<!search.php)\?[ft]=\d+$|^[^?]*(?<!search.php)$/m';
$str = 'http://www.example.com/discuss/viewtopic.php?t=19
http://www.example.com/discuss/viewforum.php?f=8
http://www.example.com/discuss/search.php?f=8
http://www.example.com/discuss/viewforum.php
http://www.example.com/discuss/search.php';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);