import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*(?<!search.php)\\?[ft]=\\d+$|^[^?]*(?<!search.php)$";
final String string = "http://www.example.com/discuss/viewtopic.php?t=19\n"
+ "http://www.example.com/discuss/viewforum.php?f=8\n"
+ "http://www.example.com/discuss/search.php?f=8\n"
+ "http://www.example.com/discuss/viewforum.php\n"
+ "http://www.example.com/discuss/search.php";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}