#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z0-9_.+-]*(?:[a-zA-Z][a-zA-Z0-9_.+-]*){2,}$"
Local $sString = "123a123b123" & @CRLF & _
"ab123de" & @CRLF & _
"123ab123" & @CRLF & _
"123ab" & @CRLF & _
"a123b" & @CRLF & _
"" & @CRLF & _
"123a" & @CRLF & _
"a123" & @CRLF & _
"1a23"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")