$re = '/^[a-zA-Z0-9_.+-]*(?:[a-zA-Z][a-zA-Z0-9_.+-]*){2,}$/m';
$str = '123a123b123
ab123de
123ab123
123ab
a123b
123a
a123
1a23';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);