import re
regex = re.compile(r"^[a-zA-Z0-9_.+-]*(?:[a-zA-Z][a-zA-Z0-9_.+-]*){2,}$", flags=re.MULTILINE)
test_str = ("123a123b123\n"
"ab123de\n"
"123ab123\n"
"123ab\n"
"a123b\n\n"
"123a\n"
"a123\n"
"1a23")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")