package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9_.+-]*(?:[a-zA-Z][a-zA-Z0-9_.+-]*){2,}$`)
var str = `123a123b123
ab123de
123ab123
123ab
a123b
123a
a123
1a23`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}