# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<(?:(?:img)(?=[\s>\\/])(?:[^>=]|=(?:'[^']*'|"[^"]*"|[^'"\s>]*))*\s?\\/?>|(a|span|pre|code|strong|b|em|i)(?=[\s>\\])(?:[^>=]|=(?:'[^']*'|"[^"]*"|[^'"\s>]*))*\s?\\/?>.*?<\\/\1>)|(?:"[^"]*"|[^"<]*)*/$1$2/gsix;t' <<< "<b>test</b> or <strong> this </strong><em> oh yeah </em> and <i>oh yeah</i> Here we are \"ye we 'hold' it\"
some<img/>gfsf<a html=\"droids.html\" onmouseover=' var x=\" Not the droid I am looking for \" ; '>droides</a><pre></pre><code></code><strong></strong><b></b><em></em><i></i>"